Help - Main menu

From TreeGraph help
Jump to: navigation, search

The main menu is the major way to access all functions of TreeGraph 2. (Note that most functions can also be accessed by the tool bar, the context menu or a keyboard shortcut.)

An option followed by "..." means that a dialog will be displayed which asks you for further parameters for this function (e.g. Save as...). Other options do not need further parameters (e.g. Select all).

ArticleOnLatestVersion.png This article describes this feature for the latest version of TreeGraph 2. For older versions the following articles are available:
Main menu (until 2.0.22), Main menu (until 2.0.23), Main menu (until 2.0.34), Main menu (until 2.0.42), Main menu (until 2.0.49), Main menu (until 2.1.0), Main menu (until 2.5.0), Main menu (until 2.12.0)


File menu

The file menu contains all options related to opening and saving of tree files and graphic files.

Document management

Option: Function:
New Creates a new (unsaved) tree document and opens it in the editor.
Open... Displays a dialog to open a tree file. This option can either be used to open a TreeGraph 2-document (*.xtg) or to import a document in another tree format (e.g. Nexus). (See Open files for details.)
Save Saves the tree file which is currently focused. If this file has just been created you will be asked to specify a file name (same as Save as..).
Save as... Displays a dialog to save the tree file which is currently focused at a new position.
Close Closes the tree file which is currently focused. If that file is unsaved you will be asked whether to save recent changes.

Importing

Option: Function:
Add support values... Allows you to import additional node/branch data (e.g. support values) from another tree file into the currently focused tree. (See Adding support values for details.)
Import table as node/branch data... Imports a new node/branch data column from a text file. (See Importing node/branch data for details.)
Import BayesTraits data... Allows importing ancestral state probabilities directly from output files of the software BayesTraits. (See Importing ancestral state probabilities from BayesTraits for details.) This feature was not available before version 2.5.0.

The Apply name tables function was only available in previous versions. Since version 2.0.50 it has bee integrated into the extended Importing node/branch data function.

Exporting

Option: Function:
Export to graphic/PDF... Allows to export the tree in the currently focused file to a graphic file or a PDF. (See Exporting trees as graphics for details.)
Export to tree format... Allows to export the tree in the currently focused file to a Newick or Nexus tree file. (See Exporting trees as Newick/Nexus files for details.) This entry was called "Export to Newick/Nexus" before version 2.6.0.
Export node/branch data as table... Allows to export several node/branch data columns to a text file. (See Exporting node/branch data for details.)
Generate BayesTraits input... Allows to generate commands from nodes in the currently opened tree that can be used in a BayesTraits analysis. (See Generating Bayes Traits input for details.) This feature was not available before version 2.6.0.

Exporting pie chart captions

Option: Function:
Create label caption document Opens a new document window containing the captions for all labels of the currently selected branch (See Creating label captions for details.) This feature was not available before version 2.13.0.
Export pie chart label colors... Allows to export a text file containing a table listing the colors used in the pie chart labels on the currently selected branch. (See Exporting pie chart label colors for details.) This feature was not available before version 2.12.0.

Exit

Option: Function:
Exit Terminates TreeGraph 2. (You will be asked whether to save open tree files.)

Select menu

This menu contains options that allow you to select different parts of the currently focused tree. All options can be combined, i.e. all elements selected by an option of this menu are added to previous selection. (See Selecting elements for details on the options described here.) Additionally a feature to select according nodes in other opened trees exists since version 2.5.0.

Selecting groups of elements

Option: Function:
Select all Selects all elements in the tree (including all legends and the scale bar if present).
Invert selection Selects all elements in the tree (including all legends and the scale bar if present) which are currently not selected. All currently selected elements are removed from the selection.
Select subtree(s) Selects all elements in the subtree(s) under the currently selected elements (not including any legends).
Search text... Selects all text elements which contain a certain text. (See Search text for details. This option is also contained in the Edit menu.)
Select this type(s) in document Selects all elements in the whole document which have the same type as the currently selected elements.
Select this type(s) in subtree(s) Selects all elements in the subtree(s) under the previously selected elements which have the same type as the respective selected root elements.
Select leaves in document Selects all leaf-nodes and -branches of the tree.
Select leaves in subtree(s) Selects all leaf-nodes and -branches that are contained in one of the subtrees under the currently selected elements.
Select labels with this ID Selects all labels that have the same ID as one of the currently selected labels.
Select labels in subtree(s) Selects all labels that are contained in one of the subtrees under the currently selected elements.
Select all legends Selects all legends in the document.
Select legends with the same position index Selects only such legends that have the same position index as the currently selected legend(s). (See the Legend article to find out what the position index is.)

Synchronizing selection

Option: Function:
Synchronize tree selection When nodes are selected while this function is active, according nodes or conflicts in other opened trees will be selected as well. (See Synchronizing tree selections for details.) This feature was not available before version 2.5.0.
Tree selection compare parameters... This dialog contains some options on how trees should be compared during selection synchronization. (See Synchronizing tree selections for details.) This feature was not available before version 2.5.0.

Edit menu

This menu contains all options that manipulate the structure of a TreeGraph document like adding, deleting, moving document elements or changing the contents of any node/branch data.

Undo/Redo

Option: Function:
Undo Lists the last operations that have been performed on this document and allows you to undo them. (The selected operation and all operations that were performed afterwards are undone.)
Redo Lists the last operations that have been undone and allows you to redo them. (The selected operation and all operations that were performed before are redone.)

Add elements

This options are located in the New-submenu.

Option: Function:
New node Inserts a new node at the selected position. (See Inserting nodes for details.)
New text label... Adds a new text label to the currently selected branch.
New legend Inserts a new legend into the document which is anchored at the currently selected node(s). (See Anchoring legends for details.)

Paste/ copy/ delete

Option: Function:
Copy Copies the currently selected element to the clipboard. (See Copying/cutting document elements for details.)
Copy all labels Copies all labels on the currently selected branch to the clipboard. (See Copying/cutting document elements for details.)
Cut Copies the currently selected element to the clipboard and removes it from the document. (See Copying/cutting document elements for details.)
Paste Inserts the content of the clipboard at the selected position. (See Copying/cutting document elements, Inserting nodes or Inserting legends for details.)
Delete Removes the currently selected elements including their subtrees. (See Deleting document elements for details. Use Collapse node if you want to remove a node without deleting its subtree.)

Node/branch data

This options are located in the Node/branch data-submenu.

Option: Function:
Set column to decimal type All string values in the currently selected column are parsed as a numeric value if possible.
Set column to textual type All numeric values in the currently selected column are converted to their string representation.
Rename data ID... You can rename the ID of a text label- or a hidden node/branch data-column here. (See Renaming IDs for details.)
Copy column... Copies the values of one node/branch data column to an new one. (See Copying node/branch data for details.)
Delete column Deleted the selected column or all values in the column if the the column itself cannot be deleted (e.g. branch lengths or node names).
Delete values outside interval Deletes all numeric values in the selected node/branch data column that are not the specified interval. (See Deleting node/branch data outside interval for details.)
Calculate node/branch data... Allows you to calculate numeric values for a node/branch data column by defining a mathematical expression. In this expression you can also reference values of other columns. (See Calculating_node/branch_data for details.)
Set default node/branch data columns... Allows you to specify the default node/branch data columns for this document. (See Default node/branch data columns for details.) This feature was not available before version 2.5.0.

Edit document elements

Option: Function:
Edit text... Displays a dialog to edit the text or title of the currently selected text element. (See Editing text element values for details.)
Edit branch length... Displays a dialog to change the branch length of the currently selected branch. Here you can also define if a branch length shall be stored at all. (See Changing branch lengths for details.)
Change label ID... Displays a dialog to change the ID of a label. (See Changing a document element ID for details.)
Edit pie chart data IDs and captions... Displays a dialog to change the IDs of the source data columns and the section captions of a pie chart label. (See Pie chart label for details.)

Search/replace

Option: Function:
Search text... Selects all text elements which contain a certain text. (See Search text for details. This option is also contained in the Select menu.)
Replace text in node/branch data... Replaces a text in a column of node/branch data. (See Replace text in node/branch data for details. This option is also available in the "Edit branch/node data"-dialog.)

Changing the global tree structure

Option: Function:
Move subtree up Moves the currently selected node (including its subtree) upwards. (See Moving nodes for details.)
Move subtree down Moves the currently selected node (including its subtree) downwards. (See Moving nodes for details.)
Ladderize up Sorts all nodes in the subtree of the currently selected node by the number of leaves contained in their subtrees. (See Ladderizing for details.)
Ladderize down Sorts all nodes in the subtree of the currently selected node by the number of leaves contained in their subtrees. (See Ladderizing for details.)
Sort terminal nodes... Sorts all nodes in the subtree of the currently selected node (or the whole document if nothing is selected) by an order defined in another opened document or a text file. (See Sorting terminal nodes for details.) This feature was not available before version 2.2.0.
Root here Reroots the tree at the currently selected position. (See Rerooting for details.)
Root by leaves Reroots the tree so that the most recent common ancestor of the selected leaf nodes becomes the new root. (See Rerooting#Rerooting by leaf nodes for details.) This feature was not available before version 2.0.52.

Changing the local tree structure

Delete subelements Deletes all subtrees under the currently selected node so that the selected node becomes a leaf.(See Deleting subelements for details.)
Collapse node Deletes the currently selected node and adds all its child nodes to its parent node. (See Collapsing nodes for details.)
Collapse nodes by support... Collapses all nodes that have a low support in a specified node/branch data column in the subtree under the currently selected node or in the whole document if nothing is selected. (See Collapsing nodes by support for details.) This feature was not available before version 2.2.0.
Separate branch Separates the currently selected branch into to branches which are separated by a new node. (See Separating branches for details.)

Format menu

This menu contains all functionalities to change the formats of tree elements (e.g. color, line width, font etc.).

Option: Function:
Document formats... Displays a dialog to change the document formats (e.g. leaf margin).
Element formats... Displays a dialog to change the element formats of the currently selected documents. This option is the key format option in TreeGraph 2. Together with the selection options you can adjust the layout of your tree very efficiently.
Scale branch lengths Calculates the distance per branch length unit so that the whole tree has a certain width. (See Scale branch lengths for details.)
Reanchor legend Sets the currently selected node(s) as the new anchors for the selected legend. (See Anchoring legends for details.)
Automatically position labels Repositions all labels on the selected branches. (See Automatically position labels for details.)
Set colors by node/branch data... Displays a dialog to adjust all colors in the document by the values of a node/branch data column. (See Set colors by node/branch data for details.)
Set distance values by node/branch data... Displays a dialog to adjust all distance value formats (e.g. line with or font height) in the document by the values of a node/branch data column. (See Set distance values by node/branch data for details.)
Scale distance values... Displays a dialog to rescale all distance value formats (e.g. line with or font height) in the document with a specified factor. (See Scaling distance values for details.)

View menu

Options contained here allow you to change the view on the tree document.

Option: Function:
Zoom to original size Displays the tree in original size. (See Zoom for details.)
Fit zoom to width and height The zoom is changed so that the document fits to the current size of the window. (See Zoom for details.)
Fit zoom to width The zoom is changed so that the tree width equals the current width of the window. (See Zoom for details.)
Fit zoom to height The zoom is changed so that the tree height equals the current height of the window. (See Zoom for details.)
Set zoom... Displays a dialog to specify a user defined zoom factor.
Rectangular cladogram Changes the view mode to Rectangular cladogram (See View modes for details.)
Phylogram/Chronogram Changes the view mode to Phylogram/Chronogram (See View modes for details.)

Window menu

This windows contains options to arrange the document windows automatically as well as a link to all opened documents which brings the according window to the front.

Option: Function:
Tile vertical Arranges all windows in rows. Windows are usually higher than wide which is in most cases the best for way to view trees. (See example below.)
Tile horizontal Arranges all windows in columns. Windows are usually wider than high. (See example below.)
Cascade Arranges all windows on top of each other. (See example below.)

Window arrangements

Help menu

This menu allows you to access this help system and information about your TreeGraph 2 installation.

Option: Function:
Contents Takes you to the Main Page of this help system.
Index Takes you to the alphabetical index of this help system.
Help about this main menu Takes you to this article.
TreeGraph 2 homepage Takes you to the TreeGraph 2 homepage. Useful to check for later versions.
About Displays the About-dialog of TreeGraph 2 which contains information about the program (including version information and the licence).

See also